PHP 7 не работает интерпретатор?


При обновлении системы иногда может получиться так, что система перестает работать, например в нашем случае обновили Ubuntu 14.04 до 18.04.
На текущий момент версия PHP 7.2.3, виртауальные хосты которые были на каких-то движках продолжали работать, а вот некоторые самописные вещие перестали, в браузере стали отображаться как plaintext.

В чем же дело?




Тэги должны обязательно начинаться и заканчиваться вот-так:

?>


Если все-таки хочется использовать старые способы, то они должны быть включены с помощью конфигурационной директивы php.ini short_open_tag, либо если PHP был сконфигурирован с опцией --enable-short-tags.

Размещено в разделе PHP

03.05.2018



Комментарии:


Нет записей, оставьте свой комментарий.