Mikrotik скрипт run after reset. Не работает?


Часто бывает нужно сбросить оборудование Mikrotik так, чтобы не было дефолтной конфигарации (No default configuration), но есть один момент, если это делается удаленно, то оборудование будет недоступно после перезагрузки.





Допустим, нам нужно решить минимальную задачу, сделать устройство доступным удаленно.



Существуюет опция run-after-reset, где можно указать пусть к скрипту, c расширением .rsc который запустится после перезагрузки. Сначала попробовал типовые команды, которые проходят в терминале, но почему-то не выполнялись при сбросе.




1 /ip address export
2 /ip route export



1 /ip address
add address=172.16.172.10/24 interface=ether1 network=172.16.172.0
2 /ip route
add distance=1 gateway=172.16.172.1


Результат объединяем в файл setup_net.rsc и помещаем его в папку flash, у меня такой по умолчанию не было, но я создал, по опеределенным соображениям.



Почему-то один раз заработало, потом безуспешно. Нашел в одном из форумов - добавить (задержку) первой строкой :delay=15s, тоже почему-то не пошло.



Методом многочисленных попыток и поиска было найдено следующее решение, также помог один из источников.


Нужно делать export c параметром terse или просто отредактировать файл чтобы он принял следующий день.




:delay=15s
1 /ip address add address=172.16.172.10/24 interface=ether1 network=172.16.172.0
2 /ip route add distance=1 gateway=172.16.172.1


Сброс с запуском скрипта:




/system reset-configuration no-defaults=yes skip-backup=yes run-after-reset=flash/setup_net.rsc


Размещено в разделе Mikrotik

18.10.2019



Комментарии:


Нет записей, оставьте свой комментарий.